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About 
 
Main > Help > About 
 
The About screen is for information purposes only and relates 1) the software name and 
version, 2) the copyright, and 3) the company name, address, website and telephone. 
 
To return to Main screen: 

• Click <OK> to return to Main screen. 
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Calibrate 
 
Main > Tools > Calibrate 
 
The Calibrate screen allows the user to calibrate the FAS-A.  Individual accelerometers 
may be calibrated as well as both accelerometers simultaneously.  Calibration gain and 
offset values are written to the on-board memory of the FAS-A. 
 
To calibrate a unit: 
Carefully read and follow the directions contained in the FAS-A Users Manual before 
you attempt to calibrate the accelerometers of an FAS-A. The following instructions 
describe the steps you follow in the software only.  

• Click <Tools>. 
• Click <Calibrate>. 
• The Calibrate screen will appear. 
• Click <File>. 
• Click <Read>. 
• The application will begin continuous sampling of the accelerometer bits and will 

display these in the Current Bit frame. 
• Physically rotate the unit about its axis as described in the Users Manual. 
• Select (by clicking the checkboxes with your mouse) the Ax or Ay accelerometer 

to calibrate accelerometers individually or All if you want to calibrate both 
together. 

• Click <File>. 
• Click <Write>. 
• You will receive a confirming message box. Click <OK>. 

 
To return to Main screen: 

• Click <File>. 
• Click <Return>. 
• Note: If you click <Return> without clicking <Write>, the current calibration on-

board the FAS-A will remain unchanged. 
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Communication Ports 
 
Main > File > Comm Port 
 
The Communication Ports screen allows the user to either select a specific serial port to 
connect to the FAS-A or to find (auto-detect) an FAS-A already connected to the 
computer’s serial ports. 
 
Note: When the software is launched, the application automatically searches for a 
configuration file and if found, sets the serial port found in the configuration file as the 
default.  If this setting occurs, a check will appear next to the <Comm Port> menu item 
on the Main screen.  The configuration file is named ‘FASASettings.ini’ and is found in a 
sub-folder under the application directory named ‘Logs’. 
 
To specify a serial port: 

• Click <File>. 
• Click <Comm Port>. 
• Using you mouse, click the “radio” button of the communications port where the 

FAS-A is connected. 
• Click <OK>. The selected port will now be used for all communications between 

the computer and the FAS-A.  
• Note: You must select a communication port in order to proceed with the 

application. If you select a serial port that doesn’t exist or is used by another 
device, you will receive errors. 

 
To auto-detect an FAS-A: 

• Click <File>. 
• Click <Comm Port>.  The Communication Port screen will appear. 
• Click the <Auto Detect> button. 
• The software will poll each of the available serial ports on your computer and find 

any FAS-A that is connected to the computer.  If an FAS-A is found, the user will 
receive a message indicating ‘FAS-A found on serial port X’.  At the same time 
the radio button of the communication port where the FAS-A was found will be 
clicked. 

• Click <OK> to set the communication port and return to the Main screen. 
• Note: If an FAS-A is not found on any of the computer’s available serial ports, 

the user will receive a message indicating ‘FAS-A not found on serial ports 1-4’.  
If this occurs, a hardware problem exists either with the computer or the FAS-A. 

 
To return to Main screen: 

• Click <OK>. 
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Configure 
 
Main > Tools > Configure 
 
The Configure screen allows the user to read and write certain settings maintained in 
memory on-board the FAS-A. These settings include gains, offsets, filtering, manual tare 
and so forth.  The settings are used to condition the FAS-A for particular situations and 
should only be changed after a thorough understanding of their effect on the device. 
 
Note: See the Using the Settings on the Configure Screen section of this Help file for 
details of each setting. 
 
To read settings: 

• Click <File>. 
• Click <Read>.  The program will retrieve the settings from the on-board memory 

of the FAS-A and display them. 
• Note: If a particular setting isn’t initialized on-board the FAS-A, a message box 

will appear indicating an address hasn’t been initialized. A default value for that 
address will be displayed. 

 
To write settings: 

• Enter a new value for a particular setting by typing the value in the scroll box or 
by scrolling the value up/down using the scroll box arrows. 

• Click <File>. 
• Click <Write>.  You will be asked to confirm the Write. 
• If you choose <Yes>, the new settings will be written to the on-board memory of 

the FAS-A.  You will receive a confirming message.  Click <OK> and the screen 
will return to the Read state.  

• If you choose <No>, the new settings will NOT be written to the on-board 
memory of the FAS-A.  You will receive a confirming message.  Click <OK> and 
the screen will return to the Read state.  

 
To show addresses: 

• Click <Tools>. 
• Click <Show Addresses>.  The memory locations and internal offsets of the 

settings on-board the FAS-A will be displayed. 
 
To show EEPROM: 

• Click <Tools>. 
• Click <EEPROM>. Follow the instructions for EEPROM screen given elsewhere 

in this Help file. 
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To see default values: 
• Click <Tools>. 
• Click <Default Values>. The default value for each of the settings on the 

configure screen will be displayed in the appropriate scroll box. 
• Note: The settings are only being displayed, they are not being set.  To set them, 

follow the ‘to write settings’ function described above.  To return to the actual 
settings, follow the ‘to read settings’ function described above. 

 
To return to Main screen: 

• Click <File>. 
• Click <Return>. 
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Display 
 
Main > Display 
 
The Display screen allows the user to display and save to file the data resulting from any 
of five sampling methods including 1) one angle, 2) two angles, 3) accelerometer bits, 4) 
one angle and bits and 5) two angles and bits. 
 
To sample one angle: 

• Click <Data>. 
• Click <Sample One Angle>.  Sampling will begin and the current angle will be 

displayed on the dial.  If the <Save> function has been initiated, angular data will 
be saved to the selected data file. 

• Note: To stop sampling, click <Sample One Angle> again and the sampling (and 
data saving) will end. 

 
To sample two angles: 

• Click <Data>. 
• Click <Sample Two Angles>.  Sampling will begin and the current angles will be 

displayed on the dials.  If the <Save> function has been initiated, angular data will 
be saved to the selected data file. 

• Note: To stop sampling, click <Sample Two Angles> again and the sampling 
(and data saving) will end. 

 
To sample bits: 

• Click <Data>. 
• Click <Sample Bits>.  Sampling will begin and the current accelerometer bits will 

be displayed on the gauges.  If the <Save> function has been initiated, bits data 
will be saved to the selected data file. 

• Note: To stop sampling, click <Sample Bits> again and the sampling (and data 
saving) will end. 

 
To sample one angle and bits: 

• Click <Data>. 
• Click <Sample One Angle and Bits>.  Sampling will begin.  The current angle 

will be displayed on the dial and the current accelerometer bits will be displayed 
on the gauges.  If the <Save> function has been initiated, angular and bits data 
will be saved to the selected data file. 

• Note: To stop sampling, click <Sample One Angle and Bits> again and the 
sampling (and data saving) will end. 
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To sample two angles and bits: 
• Click <Data>. 
• Click <Sample Two Angles and Bits>.  Sampling will begin.  The current angles 

will be displayed on the dials and the current accelerometer bits will be displayed 
on the gauges.  If the <Save> function has been initiated, angular and bits data 
will be saved to the selected data file. 

• Note: To stop sampling, click <Sample Two Angles and Bits> again and the 
sampling (and data saving) will end. 

 
To save data to a file: 

• Click <Data>. 
• Click <Save>. 
• A “common dialog” box named Save As will appear. 
• You may create a new name for the data file in the File Name textbox and select a 

file type in the Save As Type textbox or you may select an existing file as the data 
file.  Click the Save button. The common dialog will disappear. 

• A check will now appear to the left of the <Save> menu item indicating that a file 
is in place to receive data anytime sampling is active.  

  
To stop saving data to a file: 

• Click <File>. 
• Click <Save>.  The check to the left of the menu item will disappear indicating 

saving has stopped. 
 
To tare the FAS-A: 
Carefully read and follow the directions contained in the FAS-A Users Manual before 
you attempt to tare the FAS-A. The following instructions describe the steps you follow in 
the software only.  Note: The tare function is available on only those sampling methods 
which contain angle(s).  The tare ‘box’ appears after sampling has begun and disappears 
when sampling ends. 
 

• Start sampling for an angle(s). 
• The tare box appears with only the <No Tare> button enabled. 
• Click <No Tare>.  Any tare will be removed (zero’d).  The ‘zero’ tare will be 

written to the FAS-A and remain in place during future sessions until otherwise 
changed. 

• The <No Tare> button will disable and the <Tare> button will enable. 
• Click <Tare>.  The current angular offset from ‘zero’ will be captured.  The new 

tare will be written to the FAS-A and remain in place during future sessions 
unless otherwise changed. 

 
To return to Main screen: 

• Click <Data>. 
• Click <Return>. 
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EEPROM 
 
Configure > Tools > EEPROM 
Allows direct reading and writing of values in the FAS-A’s on-board memory 
(EEPROM). 
 
Note: This function writes the exact value selected. It does not provide for any 
offsets.   
 
To read a value: 

• Enter an EEPROM address in the Address scroll box. Refer to the FAS-A 
EEPROM Memory Map for particulars. 

• Click <Read>. 
• Value in address will appear in Value text box. 

 
To write a value: 

• Enter an EEPROM address in the Address scroll. Refer to the FAS-A EEPROM 
Memory Map for particulars. 

• Enter a numeric value in the Value text box. 
• Click <Write>. 
• Value will be written to the selected address. 

 
To exit EEPROM: 
Click <OK>. 
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Main 
 

First screen on program launch 
 
The Main screen allows the user to navigate to all program functions including 
communication port selection, configuration, calibration, display modes and program 
exit. 
 
To select a communications port: 

• Click <File>. 
• Click <Comm Port>.  Follow the instructions for Communication Ports screen 

given elsewhere in this Help file. 
 
To initialize connection: 

• Click <File>. 
• Click <Initialize Connection>.  The application will establish communications 

with the FAS-A and retrieve certain settings from on-board the FAS-A including 
tares. If successful, a confirming message box will appear indicating ‘FAS-A has 
been initialized’.  A check will also appear to the left of the < Initialize 
Connection > menu item.  If communications can’t be established, a message box 
will appear indicating ‘FAS has not been initialized. Check serial connection, 
power adapter, etc. for problem’. 

 
To display a sampling mode: 

• Click <Display>.  Follow the instructions for Display screen given elsewhere in 
this Help file. 

 
To calibrate: 

• Click <Tools>. 
• Click <Calibrate>.  Follow the instructions for Calibrate screen given elsewhere 

in this Help file. 
 
To configure: 

• Click <Tools>. 
• Click <Configure>.  Follow the instructions for Configure screen given elsewhere 

in this Help file. 
 
To set time save method: 

• Click <Tools>. 
• Click <Set Time Save>.  Follow the instructions for Set Time Save Method 

screen given elsewhere in this Help file. 
 
To exit the program: 

• Click <File>. 
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• Click <Exit>.  The program will terminate and communication between the FAS-
A and the host computer will cease. 
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Set Time Save Method 
 
Main > Tools > Set Time Save 
 
The Set Time Save Method allows the user to save sampling data to file either with an 
‘elapsed seconds’ format or a ‘system time’ format. 
 
To set time save method: 

• Click <Tools>. 
• Click <Set Time Save>.  The Set Time Save method screen will appear. 
• Using your mouse, click the radio button for either the <Elapsed Seconds> option 

or the <System Time> option. 
• Click <OK> to accept option and exit screen or click <Cancel> to exit screen 

without change to method. 
• Note: Each time you make a selection on this screen, the choice is written to the 

‘FASASettings.ini’ file and will become the default selection the next time the 
application is run. 
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Appendix 
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Using the Settings on the Configure Screen 
 

Ax Offset  0-4096 
The value in bits that the Ax sensor reads when 0 G is applied.  This value generally does 
not need to be changed.   

Ay Offset  0-4096 
The value in bits that the Ay sensor reads when 0 G is applied.  This value generally does 
not need to be changed. 

Ax Gain  0-4096 
The full scale swing in bits when the Ax sensor is moved throughout earth's field. This 
value generally does not need to be changed. 

Ay Gain  0-4096 
The full scale swing in bits when the Ay sensor is moved throughout earth's field. This 
value generally does not need to be changed. 

Tare 360  0-360 
Applied only in one angle mode, the Tare 360 value is an angular value that is subtracted 
from the absolute angle reading of the sensor.  This allows the user to zero the sensor in 
any orientation relative to gravity. 

Polarity  0-1 
This is the direction of increasing angle as measured by the 360 degrees axis.   

Filter   0-5 
This is the level of averaging applied to the data by a weighted moving average low-pass 
filter.   

A/D Average 0-15 
The number of digital points averaged at each sample. 

DAC   0-1 
This value enables/disables the analog output.  1 is enabled, 0 is disabled.  

Angle Mode 0-1 
This value sets the device to one angle mode or two angles mode.  1 is one angle mode, 0 
is two angles mode. 

Tare Ax  -70 to +70 
Applied only in two angles mode, the Ax Tare value is an angular value that is subtracted 
from the absolute Ax angle reading of the sensor.  This allows the user to zero the sensor 
in any orientation relative to gravity. 
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Tare Ay  -70 to +70  
Applied only in two angles mode, the Ay Tare value is an angular value that is subtracted 
from the absolute Ay angle reading of the sensor.  This allows the user to zero the sensor 
in any orientation relative to gravity. 

 


