MICROSTRAIN, INC.
Microminiature Sensors

3DM-GX1 Data Acquisition & Display Software
Table of Contents

This manual is laid out by program section and individual screen names.

**MAIN SCREEN**........................................................................................................................................ 4

**FILE SECTION**...................................................................................................................................... 6

CONNECT.................................................................................................................................................. 7

**TOOLS SECTION** .................................................................................................................................. 9

EEPROM MAP............................................................................................................................................. 10
GET Firmware and SERIAL............................................................................................................................. 12
GET TEMPERATURE..................................................................................................................................... 13
HARD IRON CALIBRATION............................................................................................................................... 14
SET CONTINUOUS/POLED MODE ................................................................................................................ 15
SET DATA ACQUISITION SAMPLING RATE.................................................................................................. 16

**DISPLAY SECTION**................................................................................................................................. 17

EULER ANGLES............................................................................................................................................ 18
EULER ANGLES, ACCELERATION AND RATE VECTORS............................................................................. 20
ORIENTATION MATRIX................................................................................................................................ 21
QUATERNIONS.............................................................................................................................................. 23
QUATERNIONS AND VECTORS....................................................................................................................... 25
SENSOR BITS.............................................................................................................................................. 27
VECTORS..................................................................................................................................................... 28

**HELP SECTION**..................................................................................................................................... 30

HELP........................................................................................................................................................... 31
ABOUT....................................................................................................................................................... 32

**ADVANCED FUNCTIONS**......................................................................................................................... 33
Main Screen
First screen on program launch

The Main screen allows the user to navigate to all program functions including connection, configuration, utilities, sampling and display screens and program exit.

To connect to the 3DM-GX1:
• Click <File>.
• Click <Connect>. Follow the instructions for the Connect screen given elsewhere in this Help file.

To configure the 3DM-GX1:
• Click <Tools>.
• Click <EEPROM Map>. Follow the instructions for the EEPROM Map screen given elsewhere in this Help file.

To Set Data Acquisition Sampling Rate, Set Continuous/Polled Mode, Get Temperature or Get Firmware and Serial:
• Click <Tools>.
• Click one of the screens available:
  o <Set Data Acquisition Sampling Rate>
  o <Set Continuous/Polled Mode>
  o <Get Temperature>
  o <Get Firmware and Serial>
• The selected screen will appear for further use. Follow the instructions for the particular screen given elsewhere in this Help file.

To sample the 3DM-GX1:
• Click <Display>.
• Click one of the 7 sampling screens available:
  o <Euler Angles>
  o <Euler Angles, Acceleration and Rate Vectors>
  o <Orientation Matrix>
  o <Quaternions>
  o <Quaternions and Vectors>
  o <Sensor Bits>
  o <Vectors>
• The selected display screen will appear for further use. Follow the instructions for the particular screen given elsewhere in this Help file.
To perform Hard Iron Field Calibration:
- Click <Tools>.
- Click <Hard Iron Calibration>. Follow the instructions for the Hard Iron Calibration screen given elsewhere in this Help file.

To exit the program:
- Click <File>.
- Click <Exit>. The program will terminate and communication between the 3DM-GX1 and the host computer will cease.
File section
**Connect**

From Main screen
Click <File>
Click <Connect>

The Connect screen allows the user to 1) auto detect the serial port and baud rate of the 3DM-GX1, confirm communications with the host and automatically load operating parameters, 2) manually enter the serial port and baud rate of the 3DM-GX1, confirm communications with the host and automatically load operating parameters and, 3) reset the Calculation Cycle to its default on the 3DM-GX1 in advance of the auto detect or manual functions.

**Note:** When the program is launched, it automatically retrieves the previously used serial port and baud rate from the MS-Windows System Registry. In its absence it defaults to serial port 1 and baud rate 38400.

**To auto detect the 3DM-GX1:**
- Click <Auto> tab.
- Click <Connect>.
- The program will automatically test for the 3DM-GX1 on serial ports 1-16 and at baud rates of 38,400, 115,200 and 19,200.
- If the 3DM-GX1 is located, the serial port and baud rate will be automatically selected and a confirming message will appear. Click <OK> and the Connect screen will disappear. You may now proceed with sampling or other program functions.
- If the 3DM-GX1 is not located, a message will appear indicating that the auto detect has failed. Proceed to troubleshoot the problem and either click <Retry> or <Cancel>.
- Click <Quit> at any time to leave the Connect screen.

**To manually select a serial port and baud rate for the 3DM-GX1:**
- Click <Manual> tab.
- Select a serial port in the value scroll box.
- Select a baud rate by clicking its radio button.
- Click <Connect>.
- If the 3DM-GX1 is located on that serial port and at that baud rate, a confirming message will appear. Click <OK> and the Connect screen will disappear. You may now proceed with sampling or other program functions.
- If the 3DM-GX1 is not located, a message will appear indicating that the manual detect has failed. Proceed to troubleshoot the problem and either click <Retry> or <Cancel>.
- Click <Quit> at any time to leave the Connect screen.
Hints: If you select a serial port that doesn’t exist or is used by another device, you will receive errors. If you select a baud rate that is different than the baud rate set on-board the 3DM-GX1, you will receive errors.

To reset the Calculation Cycle of the 3DM-GX1:
- Click <Reset> tab.
- Click <Reset>.
- The program will attempt to locate and reset the 3DM-GX1 on serial ports 1-16 and at baud rates of 38,400, 115,200 and 19,200.
- A confirming message will appear. Click <OK>.
- Cycle the power on the 3DM-GX1.
- Proceed to the Auto or Manual tabs to attempt communication.
Tools section
EEPROM Map
From Main screen
Click <Tools>
Click <EEPROM Map>

The EEPROM Map screen allows the user to read all parameters and to write certain parameters maintained in memory on-board the 3DM-GX1. These parameters include baud rate, comm mode, node address, compensation, gains, operating mode, tare and analog output. The parameters are used to condition the 3DM-GX1 for operation and should only be changed with a thorough understanding of their effect on the device.

To read parameters:
- Click <File>.
- Click <Read>. The program will retrieve the parameters from the on-board memory of the 3DM-GX1 and display them.
- A confirming message box will appear indicating the read has completed. Click <OK>.
- N.B. If a particular parameter isn’t read by the program, a message box will appear indicating a Read EEPROM Error. Note the EEPROM address and click <Retry> to continue trying to read the particular parameter. Click <Cancel> to skip the particular parameter and continue reading other parameters.

To write parameters:
- Enter a new value for a particular parameter by typing the value in the scroll box or by scrolling the value up/down using the scroll box arrows
- Click <File>.
- Click <Write>. The program will write the new parameters to the on-board memory of the 3DM-GX1.
- A confirming message box will appear indicating the write has completed. Click <OK>.
To view a parameter matrix:
- Click <File>.
- Click <View Matrix>. The View Matrix window will appear.
- In the Select frame, select the radio button of the particular matrix to view.
- The selected matrix will be displayed in the matrix frame.
- Click <Close> to close the View Matrix window.

To return to Main screen:
- Click <File>.
- Click <Return>.
Get Firmware and Serial

From Main screen
Click <Tools>
Click <Get Firmware and Serial>

The Get Firmware and Serial screen is for informational purposes only and shows the firmware version and serial number of the 3DM-GX1.

To return to Main screen:
- Click <OK> to return to Main screen.
**Get Temperature**

From Main screen
Click <Tools>
Click <Get Temperature>

The Get Temperature screen allows the user to view the current temperature on-board the 3DM-GX1.

**To view temperature:**
- Click <Get>. The current temperature will be displayed in several scales.

**To return to Main screen:**
- Click <OK> to return to Main screen.
**Hard Iron Calibration**

From Main screen
Click <Tools>
Click <Hard Iron Calibration>

The Hard Iron Calibration screen allows the user to initialize, collect and compute a hard iron field calibration for the 3DM-GX1. *Initialize* prepares the calibration algorithm, erases any previous calibration and returns the 3DM-GX1 to its factory default. *Collect* gathers any number of data points for use in the algorithm. *Compute* will process all data points and write corresponding calibration parameters to the 3DM-GX1’s non-volatile memory.

**To initialize:**
- In the Settings frame, select Calibration Type.
- In the Settings frame, enter Magnitude Z.
- Click <File>.
- Click <Initialize Hard Iron Field Calibration>.
- A confirming message will appear. Click <OK>.

**To start collecting:**
- Click <File>.
- Click <Collect Hard Iron Calibration Data>. A check will occur to the left of the menu item indicating sampling is in progress.
- The program will start sampling the 3DM-GX1 and will continuously display the magnetic field data.

**To stop collecting:**
- Click <File>.
- Click <Collect Hard Iron Calibration Data>. The check to the left of the menu item will disappear indicating sampling has stopped.

**To compute:**
- Click <File>.
- Click <Compute Hard Iron Field Calibration>. The data points collected will be processed and written to memory.
- A confirming message will appear. Click <OK>.

**To return to Main screen:**
- Click <File>.
- Click <Return>.
**Set Continuous/Polled Mode**

From Main screen
Click <Tools>
Click <Set Continuous/Polled Mode>

The Set Continuous/Polled Mode screen allows the user to set the command mode of the 3DM-GX1. The 3DM-GX1 may be placed in the Polled mode or any one of several Continuous modes.

**N.B.** This program uses Polled mode exclusively. Setting the mode to other than polled mode will be negated if the user does not exit the program and continues using other screens in the program.

**To set mode:**
- Click the <Radio Button> next to the mode you want to select. A bullet will appear indicating selection.
- Click <OK>. The mode will be set and a confirming message will appear.
- Click <OK>. You will be returned to the Main screen.

**To return to Main screen without setting mode:**
- Click <Cancel> and the Set Continuous/Polled Mode screen will disappear.
Set Data Acquisition Sampling Rate

From Main screen
Click <Tools>
Click <Set Sampling Rate>

The Set Data Acquisition Sampling Rate screen allows the user to either 1) set the
number of samples per second at which the program displays and writes data to file or 2)
set the program to display and write data to file as fast as it will go during a sampling
session.

To set maximum operation:
- Click the <Check Box> to the left of the Maximum (default) label until a check
  appears indicating selection.
- Click <OK>. The Maximum sampling rate will be set and the screen will
disappear.

To set samples per second:
- Click the <Check Box> to the left of the Maximum (default) label until a check
  no longer appears.
- Enter a number in the Samples per Second scroll box either by scrolling the
  up/down arrows or by entering the number through your keyboard. The settable
  range is 0.01 to 157 samples per second.
- Click <OK>. The sampling rate interval will be set and the screen will disappear.

To return to Main screen without setting sampling rate:
- Click <Cancel> and the Set Data Acquisition Sampling Rate screen will
disappear.
Display section
Euler Angles
From Main screen
Click <Display>
Click <Euler Angles>

The Euler Angles screen allows the user to visualize either a Gyro-Stabilized or an Instantaneous pitch, yaw and roll angles sampling session via three aircraft-type dials. The screen allows the user to start a session, record a session, capture bias and stop a session.

To start Gyro-Stabilized sampling:
- Click <Data>.
- Click <Sample Gyro-Stabilized>. A check will occur to the left of the menu item indicating sampling is in progress.
- The program will start sampling the 3DM-GX1 and will display the pitch, yaw and roll angles of the unit.

To stop Gyro-Stabilized sampling:
- Click <Data>.
- Click <Sample Gyro-Stabilized>. The check to the left of the menu item will disappear indicating sampling has stopped.

To start Instantaneous sampling:
- Click <Data>.
- Click <Sample Instantaneous>. A check will occur to the left of the menu item indicating sampling is in progress.
- The program will start sampling the 3DM-GX1 and will display the pitch, yaw and roll angles of the unit.

To stop Instantaneous sampling:
- Click <Data>.
- Click <Sample Instantaneous>. The check to the left of the menu item will disappear indicating sampling has stopped.

To capture bias:
- Click <Data>.
- Click <Capture Bias>.
To save data to a file:
   • Click <Data>.
   • Click <Save>.
   • A “common dialog” box named Save As will appear.
   • You may create a new name for the data file in the File Name textbox and select a file type in the Save As Type textbox or you may select an existing file as the data file. Click the Save button. The common dialog will disappear.
   • A check will now appear to the left of the <Save> menu item indicating that a file is in place to receive data anytime sampling is active.

To stop saving data to a file:
   • Click <Data>.
   • Click <Save>. The check to the left of the menu item will disappear indicating saving has stopped.

To return to Main screen:
   • Click <Data>.
   • Click <Return>.
Euler Angles, Acceleration and Rate Vectors

From Main screen
Click <Display>
Click <Euler Angles, Acceleration and Rate Vectors>

The Euler Angles, Acceleration and Rate Vectors screen allows the user to visualize a sampling session. The screen allows the user to start a session, record a session, capture bias and stop a session.

To start sampling:
- Click <Data>.
- Click <Sample>. A check will occur to the left of the menu item indicating sampling is in progress.
- The program will start sampling the 3DM-GX1 and display the data.

To stop sampling:
- Click <Data>.
- Click <Sample>. The check to the left of the menu item will disappear indicating sampling has stopped.

To capture bias:
- Click <Data>.
- Click <Capture Bias>.

To save data to a file:
- Click <Data>.
- Click <Save>.
- A “common dialog” box named Save As will appear.
- You may create a new name for the data file in the File Name textbox and select a file type in the Save As Type textbox or you may select an existing file as the data file. Click the Save button. The common dialog will disappear.
- A check will now appear to the left of the <Save> menu item indicating that a file is in place to receive data anytime sampling is active.

To stop saving data to a file:
- Click <Data>.
- Click <Save>. The check to the left of the menu item will disappear indicating saving has stopped.

To return to Main screen:
- Click <Data>.
- Click <Return>.
Orientation Matrix

From Main screen
Click <Display>
Click <Orientation Matrix>

The Orientation Matrix screen allows the user to conduct either a Gyro-Stabilized or an Instantaneous orientation matrix sampling session. The screen allows the user to start a session, record a session, capture bias and stop a session.

To start Gyro-Stabilized sampling:
- Click <Data>.
- Click <Sample Gyro-Stabilized>. A check will occur to the left of the menu item indicating sampling is in progress.
- The program will start sampling the 3DM-GX1 and will display the orientation matrix of the unit.

To stop Gyro-Stabilized sampling:
- Click <Data>.
- Click <Sample Gyro-Stabilized>. The check to the left of the menu item will disappear indicating sampling has stopped.

To start Instantaneous sampling:
- Click <Data>.
- Click <Sample Instantaneous>. A check will occur to the left of the menu item indicating sampling is in progress.
- The program will start sampling the 3DM-GX1 and will display the orientation matrix of the unit.

To stop Instantaneous sampling:
- Click <Data>.
- Click <Sample Instantaneous>. The check to the left of the menu item will disappear indicating sampling has stopped.

To capture bias:
- Click <Data>.
- Click <Capture Bias>.
To save data to a file:
- Click <Data>.
- Click <Save>.
- A “common dialog” box named Save As will appear.
- You may create a new name for the data file in the File Name textbox and select a file type in the Save As Type textbox or you may select an existing file as the data file. Click the Save button. The common dialog will disappear.
- A check will now appear to the left of the <Save> menu item indicating that a file is in place to receive data anytime sampling is active.

To stop saving data to a file:
- Click <Data>.
- Click <Save>. The check to the left of the menu item will disappear indicating saving has stopped.

To return to Main screen:
- Click <Data>.
- Click <Return>.
Quaternions

From Main screen
Click <Display>
Click <Quaternions>

The Quaternions screen allows the user to conduct either a Gyro-Stabilized or an Instantaneous quaternions sampling session. The screen allows the user to start a session, record a session, capture bias and stop a session.

To start Gyro-Stabilized sampling:
• Click <Data>.
• Click <Sample Gyro-Stabilized>. A check will occur to the left of the menu item indicating sampling is in progress.
• The program will start sampling the 3DM-GX1 and will display the quaternions of the unit.

To stop Gyro-Stabilized sampling:
• Click <Data>.
• Click <Sample Gyro-Stabilized>. The check to the left of the menu item will disappear indicating sampling has stopped.

To start Instantaneous sampling:
• Click <Data>.
• Click <Sample Instantaneous>. A check will occur to the left of the menu item indicating sampling is in progress.
• The program will start sampling the 3DM-GX1 and will display the quaternions of the unit.

To stop Instantaneous sampling:
• Click <Data>.
• Click <Sample Instantaneous>. The check to the left of the menu item will disappear indicating sampling has stopped.

To capture bias:
• Click <Data>.
• Click <Capture Bias>.
To save data to a file:
- Click <Data>.
- Click <Save>.
- A “common dialog” box named Save As will appear.
- You may create a new name for the data file in the File Name textbox and select a file type in the Save As Type textbox or you may select an existing file as the data file. Click the Save button. The common dialog will disappear.
- A check will now appear to the left of the <Save> menu item indicating that a file is in place to receive data anytime sampling is active.

To stop saving data to a file:
- Click <Data>.
- Click <Save>. The check to the left of the menu item will disappear indicating saving has stopped.

To return to Main screen:
- Click <Data>.
- Click <Return>.
Quaternions and Vectors

From Main screen
Click <Display>
Click <Quaternions and Vectors>

The Quaternions and Vectors screen allows the user to conduct either a Gyro-Stabilized Quaternions and Compensated Vectors or a Gyro-Stabilized Quaternions and Instantaneous Vectors sampling session. The screen allows the user to start a session, record a session, capture bias and stop a session.

To start Gyro-Stabilized Quaternions and Compensated Vectors sampling:
- Click <Data>.
- Click <Sample Gyro-Stabilized Quaternions and Compensated Vectors>. A check will occur to the left of the menu item indicating sampling is in progress.
- The program will start sampling the 3DM-GX1 and will display the data.

To stop Gyro-Stabilized Quaternions and Compensated Vectors sampling:
- Click <Data>.
- Click <Sample Gyro-Stabilized Quaternions and Compensated Vectors>. The check to the left of the menu item will disappear indicating sampling has stopped.

To start Gyro-Stabilized Quaternions and Instantaneous Vectors sampling:
- Click <Data>.
- Click <Sample Gyro-Stabilized Quaternions and Instantaneous Vectors>. A check will occur to the left of the menu item indicating sampling is in progress.
- The program will start sampling the 3DM-GX1 and will display the data.

To stop Gyro-Stabilized Quaternions and Instantaneous Vectors sampling:
- Click <Data>.
- Click <Sample Gyro-Stabilized Quaternions and Instantaneous Vectors>. The check to the left of the menu item will disappear indicating sampling has stopped.

To capture bias:
- Click <Data>.
- Click <Capture Bias>.
**To save data to a file:**
- Click <Data>.
- Click <Save>.
- A “common dialog” box named Save As will appear.
- You may create a new name for the data file in the File Name textbox and select a file type in the Save As Type textbox or you may select an existing file as the data file. Click the Save button. The common dialog will disappear.
- A check will now appear to the left of the <Save> menu item indicating that a file is in place to receive data anytime sampling is active.

**To stop saving data to a file:**
- Click <Data>.
- Click <Save>. The check to the left of the menu item will disappear indicating saving has stopped.

**To return to Main screen:**
- Click <Data>.
- Click <Return>.
**Sensor Bits**

From Main screen
Click <Display>
Click <Sensor Bits>

The Sensor Bits screen allows the user to conduct a sensor bits sampling session. The screen allows the user to start a session, record a session and stop a session.

**To start sampling:**
- Click <Data>.
- Click <Sample>. A check will occur to the left of the menu item indicating sampling is in progress.
- The program will start sampling the 3DM-GX1 and will display the sensor bits of the unit.

**To stop sampling:**
- Click <Data>.
- Click <Sample>. The check to the left of the menu item will disappear indicating sampling has stopped.

**To save data to a file:**
- Click <Data>.
- Click <Save>.
- A “common dialog” box named Save As will appear.
- You may create a new name for the data file in the File Name textbox and select a file type in the Save As Type textbox or you may select an existing file as the data file. Click the Save button. The common dialog will disappear.
- A check will now appear to the left of the <Save> menu item indicating that a file is in place to receive data anytime sampling is active.

**To stop saving data to a file:**
- Click <Data>.
- Click <Save>. The check to the left of the menu item will disappear indicating saving has stopped.

**To return to Main screen:**
- Click <Data>.
- Click <Return>.
Vectors

From Main screen
Click <Display>
Click <Vectors>

The Vectors screen allows the user to conduct either a Gyro-Stabilized or an Instantaneous vectors sampling session. The screen allows the user to start a session, record a session, capture bias and stop a session.

To start Gyro-Stabilized sampling:
- Click <Data>.
- Click <Sample Gyro-Stabilized>. A check will occur to the left of the menu item indicating sampling is in progress.
- The program will start sampling the 3DM-GX1 and will display the vectors of the unit.

To stop Gyro-Stabilized sampling:
- Click <Data>.
- Click <Sample Gyro-Stabilized>. The check to the left of the menu item will disappear indicating sampling has stopped.

To start Instantaneous sampling:
- Click <Data>.
- Click <Sample Instantaneous>. A check will occur to the left of the menu item indicating sampling is in progress.
- The program will start sampling the 3DM-GX1 and will display the vectors of the unit.

To stop Instantaneous sampling:
- Click <Data>.
- Click <Sample Instantaneous>. The check to the left of the menu item will disappear indicating sampling has stopped.

To capture bias:
- Click <Data>.
- Click <Capture Bias>.
To save data to a file:
- Click <Data>.
- Click <Save>.
- A “common dialog” box named Save As will appear.
- You may create a new name for the data file in the File Name textbox and select a file type in the Save As Type textbox or you may select an existing file as the data file. Click the Save button. The common dialog will disappear.
- A check will now appear to the left of the <Save> menu item indicating that a file is in place to receive data anytime sampling is active.

To stop saving data to a file:
- Click <Data>.
- Click <Save>. The check to the left of the menu item will disappear indicating saving has stopped.

To return to Main screen:
- Click <Data>.
- Click <Return>.
Help section
Help
From Main screen
Click <Help>
Click <Help>

The Help menu item launches Adobe Acrobat which in turn displays this 3DM-GX1 Help file (in .pdf format).
**About**

From Main screen
Click <Help>
Click <About>

The About screen is for informational purposes only and relates 1) the software name and version, 2) the copyright, and 3) the company name, address, website and telephone.

**To return to Main screen:**
- Click <OK> to return to Main screen.
3DM-GX1 Data Acquisition and Display software version 2.0.4 has several advanced functions which are not visible on program launch.

These functions include:
- Access to all EEPROM addresses
- Log EEPROM
- Analog Output
- Tare Coordinate System
- Remove Tare Coordinate System
- Read/Write System Gains
- Vertical Gyro Mode
- Self Test
- Set Calculation Cycle

These functions are described in the 3DM-GX1 Data Communications Protocol manual.

Users may contact MicroStrain Support to learn how to access these functions.