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About 
 
Main > Help > About 
 
The About screen is for information purposes only and relates 1) the software name and 
version, 2) the copyright, and 3) the company name, address, website and telephone. 
 
To return to Main screen: 

• Click <OK> to return to Main screen. 
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Configuration 
 
Main > Tools > Configuration 
 
The Configuration screen allows the user to read and write certain parameters maintained 
in memory on-board the 3DM. These parameters include filtering, tares, baud rate and 
mode.  The parameters are used to condition the 3DM for particular situations and should 
only be changed after a thorough understanding of their effect on the device. 
 
Note: See the Using the Parameters on the Configuration Screen section of this Help file 
for details of each setting. 
 
To read settings: 

• Click <File>. 
• Click <Read>.  The program will retrieve the parameters from the on-board 

memory of the 3DM and display them. 
• You will receive a confirming message indicating that the read was successful. 

Click <OK>. 
 
To write settings: 

• Change particular parameters by scrolling values up/down or by entering values 
through the keyboard.  In the case of baud rate, select the appropriate radio 
button. 

• Click <File>. 
• Click <Write>.  The new parameters will be written to the on-board memory of 

the 3DM.  You will receive a confirming message indicating that the write was 
successful.  Click <OK>. 

• You will receive an informational message indicating what to do if you changed 
the baud rate.  Click <OK>. 

• The software will re-read the parameters from the on-board memory of the 3DM 
and display them.  

 
To return to Main screen: 

• Click <File>. 
• Click <Return>. 
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Connect 
 
Main > File > Connect 
 
The Connect screen allows the user to set the serial port and the baud rate for 
communication with the 3DM and to auto-detect the 3DM. 
 
To set comm port and baud rate: 

• Using your mouse, click the radio button of the host comm port which is 
connected to the 3DM. 

• Using your mouse, click the radio button of the baud rate which was previously 
set for the 3DM.  The factory default is 9600 baud. 

• Click <OK>.  The application will attempt communication with the 3DM. 
• If communication is successful, you will receive a confirming message.  Click 

<OK> and the Connect screen will disappear. You may then proceed with the 
application. 

• If communication is unsuccessful, you will receive a message indicating various 
possibilities for the failure.  Click <OK> and the Connect screen will disappear. 
You may then proceed with determining and correcting the cause for failure.  You 
must achieve a successful connection to proceed with the application. 

 
To auto detect the 3DM: 

• If you do not know what comm port and/or baud rate to set for the 3DM, click 
<Auto Detect>. 

• The application will automatically test all comm ports and all baud rates until 
communication is established with the 3DM. 

• If auto detection is successful, a confirming message will appear indicating which 
comm port and baud rate were detected.  Click the message box <OK> and the 
appropriate radio buttons will be automatically selected.  Click <OK> again and a 
connection will be established as normal. 

• If auto detection is unsuccessful, you will receive a message indicating that the 
3DM was not detected.  Click the message box <OK>.  Click <OK> again and a 
message will appear indicating various possibilities for the failure.  Click the 
message box <OK> and the Connect screen will disappear. You should then 
proceed with determining and correcting the cause for failure.  You must achieve 
a successful connection to proceed with the application. 
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Euler Angles 
 
Main > Display > Euler Angles 
 
The Euler Angles screen allows the user to visualize an aircraft angles data acquisition 
session through a “pitch” dial, a “yaw” dial and a “roll” dial.  The screen allows the user 
to start a session, record a session and stop a session. 
 
To begin sampling a 3DM: 

• Click <Data>. 
• Click <Sample>. A check will occur to the left of the menu item indicating 

sampling is in progress. 
• The application will begin sampling the 3DM and will display the pitch, yaw and 

roll angles of the unit. 
 
To stop sampling a 3DM: 

• Click <Data>. 
• Click <Sample>. The check to the left of the menu item will disappear indicating 

sampling has stopped. 
 
To save data to a file: 

• Click <Data>. 
• Click <Save>. 
• A “common dialog” box named Save As will appear. 
• You may create a new name for the data file in the File Name textbox and select a 

file type in the Save As Type textbox or you may select an existing file as the data 
file.  Click the Save button. The common dialog will disappear. 

• A check will now appear to the left of the <Save> menu item indicating that a file 
is in place to receive data anytime sampling is active.  

  
To stop saving data to a file: 

• Click <Data>. 
• Click <Save>.  The check to the left of the menu item will disappear indicating 

saving has stopped. 
 
To return to Main screen: 

• Click <Data>. 
• Click <Return>. 
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Get Firmware and Serial 
 
Main > Tools > Get Firmware and Serial 
 
The Get Firmware and Serial screen is for information purposes only and relates 1) the 
firmware version of the 3DM and 2) the serial number of the 3DM. 
 
To return to Main screen: 

• Click <OK> to return to Main screen. 
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Get Temperature 
 
Main > Tools > Get Temperature 
 
The Get Temperature screen allows the user to retrieve the instantaneous temperature 
from the temperature sensor on-board the 3DM circuit board. 
 
To get the temperature: 

• Click <Get>. The instantaneous temperature will be displayed.  Repeated clicks of 
the <Get> button will retrieve new temperature readings. 

 
To return to Main screen: 

• Click <OK> to return to Main screen. 
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Main 
 
First screen on program launch 
 
The Main screen allows the user to navigate to all program functions including 
connection, display, configuration, settings and program exit. 
 
To connect to the 3DM: 

• Click <File>. 
• Click <Connect>.  Follow the instructions for the Connect screen given elsewhere 

in this Help file. 
 
To display angles, matrix, vectors or bits: 

• Click <Display>. 
• Click either <Euler Angles> or <Orientation Matrix> or <Orientation Matrix and 

Vectors> or <Sensor Bits> or <Vectors>.  Follow the instructions for the 
particular screen given elsewhere in this Help file. 

 
To configure the 3DM: 

• Click <Tools>. 
• Click <Configuration>.  Follow the instructions for the Configuration screen 

given elsewhere in this Help file. 
 
To set sampling rate: 

• Click <Tools>. 
• Click < Set Sampling Rate>.  Follow the instructions for the Set Sampling Rate 

screen given elsewhere in this Help file. 
 
To set continuous/polled mode: 

• Click <Tools>. 
• Click <Set Continuous/Polled Mode>.  Follow the instructions for the Set 

Continuous/Polled Mode screen given elsewhere in this Help file. 
 
To get the 3DM’s on-board temperature: 

• Click <Tools>. 
• Click <Get Temperature>.  Follow the instructions for the Get Temperature 

screen given elsewhere in this Help file. 
 
To get firmware version and serial number: 

• Click <Tools>. 
• Click <Get Firmware and Serial>.  Follow the instructions for the Get Firmware 

and Serial screen given elsewhere in this Help file. 
 
To read about software: 

• Click <Help>. 
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• Click <About>.  Follow the instructions for the About screen given elsewhere in 
this Help file. 

 
To exit the program: 

• Click <File>. 
• Click <Exit>.  The program will terminate and communication between the 3DM 

and the host computer will cease. 
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Orientation Matrix 
 
Main > Display > Orientation Matrix 
 
The Orientation Matrix screen allows the user to visualize an orientation matrix data 
acquisition session through a 3 X 3 grid.  The screen allows the user to start a session, 
record a session and stop a session. 
 
To begin sampling a 3DM: 

• Click <Data>. 
• Click <Sample>. A check will occur to the left of the menu item indicating 

sampling is in progress. 
• The application will begin sampling the 3DM and will display the 3 X 3 

orientation matrix of the unit. 
 
To stop sampling a 3DM: 

• Click <Data>. 
• Click <Sample>. The check to the left of the menu item will disappear indicating 

sampling has stopped. 
 
To save data to a file: 

• Click <Data>. 
• Click <Save>. 
• A “common dialog” box named Save As will appear. 
• You may create a new name for the data file in the File Name textbox and select a 

file type in the Save As Type textbox or you may select an existing file as the data 
file.  Click the Save button. The common dialog will disappear. 

• A check will now appear to the left of the <Save> menu item indicating that a file 
is in place to receive data anytime sampling is active.  

  
To stop saving data to a file: 

• Click <Data>. 
• Click <Save>.  The check to the left of the menu item will disappear indicating 

saving has stopped. 
 
To return to Main screen: 

• Click <Data>. 
• Click <Return>. 
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Orientation Matrix and Vectors 
 
Main > Display > Orientation Matrix and Vectors 
 
The Orientation Matrix and Vectors screen allows the user to visualize a data acquisition 
session which gathers both orientation matrix and vectors from the 3DM.  The screen 
allows the user to start a session, record a session and stop a session. 
 
To begin sampling a 3DM: 

• Click <Data>. 
• Click <Sample>. A check will occur to the left of the menu item indicating 

sampling is in progress. 
• The application will begin sampling the 3DM and will display the orientation 

matrix and vectors of the unit. 
 
To stop sampling a 3DM: 

• Click <Data>. 
• Click <Sample>. The check to the left of the menu item will disappear indicating 

sampling has stopped. 
 
To save data to a file: 

• Click <Data>. 
• Click <Save>. 
• A “common dialog” box named Save As will appear. 
• You may create a new name for the data file in the File Name textbox and select a 

file type in the Save As Type textbox or you may select an existing file as the data 
file.  Click the Save button. The common dialog will disappear. 

• A check will now appear to the left of the <Save> menu item indicating that a file 
is in place to receive data anytime sampling is active.  

  
To stop saving data to a file: 

• Click <Data>. 
• Click <Save>.  The check to the left of the menu item will disappear indicating 

saving has stopped. 
 
To return to Main screen: 

• Click <Data>. 
• Click <Return>. 
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Sensor Bits 
 
Main > Display > Sensor Bits 
 
The Sensor Bits screen allows the user to visualize a raw magnetometer and raw 
accelerometer bits data acquisition session through “vertical pointer slides”.  The screen 
allows the user to start a session, record a session and stop a session. 
 
To begin sampling a 3DM: 

• Click <Data>. 
• Click <Sample>. A check will occur to the left of the menu item indicating 

sampling is in progress. 
• The application will begin sampling the 3DM and will display the sensor bits of 

the unit. 
 
To stop sampling a 3DM: 

• Click <Data>. 
• Click <Sample>. The check to the left of the menu item will disappear indicating 

sampling has stopped. 
 
To save data to a file: 

• Click <Data>. 
• Click <Save>. 
• A “common dialog” box named Save As will appear. 
• You may create a new name for the data file in the File Name textbox and select a 

file type in the Save As Type textbox or you may select an existing file as the data 
file.  Click the Save button. The common dialog will disappear. 

• A check will now appear to the left of the <Save> menu item indicating that a file 
is in place to receive data anytime sampling is active.  

  
To stop saving data to a file: 

• Click <Data>. 
• Click <Save>.  The check to the left of the menu item will disappear indicating 

saving has stopped. 
 
To return to Main screen: 

• Click <Data>. 
• Click <Return>. 
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Set Continuous/Polled Mode 
 
Main > Tools > Set Continuous/Polled Mode 
 
The Set Continuous/Polled Mode screen allows the user to configure the 3DM so that it is 
operating in 1 of 5 continuous modes or in Polled Mode. The Continuous Mode causes 
the 3DM to output its data sets on a continuous basis.  The Polled Mode causes the 3DM 
to only output a single data set when requested by the host computer.  The purpose of this 
function is to allow the user to set the 3DM in whatever mode so that the 3DM can be 
used in a fashion other than communicating with this software.  When the 3DM is 
operated by this software, it is always in Polled Mode.  Please refer to the 3DM User 
Manual for protocol details of the various modes. 
 
To select a mode: 

• Using your mouse, click the radio button of the mode of operation. 
• Click <OK>.  The 3DM will be set to the mode selected. 
• A confirming message will appear. Click <OK>.  The Set Continuous/Polled 

Mode screen will disappear and you will be returned to the Main screen. 
 
To cancel a mode change: 

• Click <Cancel>.  The mode in effect will not be changed, the Set 
Continuous/Polled Mode screen will disappear and you will be returned to the 
Main screen. 

 



 
MicroStrain, Inc. 

 15

Set Sampling Rate 
 
Main > Tools > Set Sampling Rate 
 
The Set Sampling Rate screen allows the user to set the rate at which the 3DM is polled 
for data.  By default the application will poll for data as fast as the 3DM and host 
hardware will operate.  The use can also set the rate at which the application polls and 
writes data to file. 
 
To set the sampling rate at maximum (default): 

• With your mouse, click the check box next to Maximum so that a check mark 
appears. 

• Click <OK>.  The sampling rate will be set at maximum and the Set Sampling 
Rate screen will disappear. 

 
To set a specific sampling rate per second: 

• With your mouse, click the check box next to Maximum so that no check mark 
appears. 

• Enter a value by scrolling values up/down or by entering values through the 
keyboard into the Samples Per Second scroll box. 

• Click <OK>.  The sampling rate will be set to the value entered and the Set 
Sampling Rate screen will disappear. 
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Vectors 
 
Main > Display > Vectors 
 
The Vectors screen allows the user to visualize a magnetometer and accelerometer 
vectors data acquisition session.  The screen allows the user to start a session, record a 
session and stop a session. 
 
To begin sampling a 3DM: 

• Click <Data>. 
• Click <Sample>. A check will occur to the left of the menu item indicating 

sampling is in progress. 
• The application will begin sampling the 3DM and will display the magnetometer 

and accelerometer vectors of the unit. 
 
To stop sampling a 3DM: 

• Click <Data>. 
• Click <Sample>. The check to the left of the menu item will disappear indicating 

sampling has stopped. 
 
To save data to a file: 

• Click <Data>. 
• Click <Save>. 
• A “common dialog” box named Save As will appear. 
• You may create a new name for the data file in the File Name textbox and select a 

file type in the Save As Type textbox or you may select an existing file as the data 
file.  Click the Save button. The common dialog will disappear. 

• A check will now appear to the left of the <Save> menu item indicating that a file 
is in place to receive data anytime sampling is active.  

  
To stop saving data to a file: 

• Click <Data>. 
• Click <Save>.  The check to the left of the menu item will disappear indicating 

saving has stopped. 
 
To return to Main screen: 

• Click <Data>. 
• Click <Return>. 

 
 


